Get in touch
Back
Maintenance

Cluster Upgrade

Completed 4 Mar at 03:00pm EST.

Dashboards Analytics API Rhino.works Accounts and Billing
Completed

Maintenance completed

Posted 4 Mar at 03:00pm EST.
Started

We will be updating the services platform which will require a brief amount of downtime as we transition versions. During this time, affected services may be sporadically or wholly unavailable.

Posted 4 Mar at 01:00pm EST.