Get in touch
Back
Downtime

Issues with Account Login

Started 11 Apr at 01:04pm EDT, resolved 11 Apr at 01:39pm EDT.

Rhino.works Accounts and Billing
Resolved

This issue is now resolved.

Posted 11 Apr at 01:39pm EDT.
Updated

Heroku Support has identified that their platform is currently having an outage, which is hosting Rhino.works Accounts. We're currently trying to find a path to resolve this issue.

Posted 11 Apr at 01:12pm EDT.
Created

We're currently tracing a secondary issue with our Account System unable to process logins to Analytics. We'll update this page with any new information.

Posted 11 Apr at 01:04pm EDT.